Moodle 3.2 or later requires at least PHP 5.6.5 (currently using version 5.5.38).
Please upgrade your server software or install older Moodle version.